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Introduction

Area measurement is frequently needed in
research. ImageJ is a powerful free image
processor for this purpose and resolves the
measurement in a simple way. However, the
advantage of the countless functions from
ImageJ may be seen as confusing by begin-
ners. One frequently asked question about
area measurement is how to select the re-
gion of the image to be quantified, as a good
area estimate depends on the accurate seg-
mentation the object of interest from its back-
ground.

Segmentation can be defined as finding
the boundary between the object of interest
and its background. To do the segmenta-
tion manually for a leaf whose area is to
be measured, one needs to trace its contour.
Here I discuss how to automate this process
through image processing.

ImageJ (Schneider et al. 2012) is a powerful
image processor, focusing on scientific ima-
ging analyses. It is free open source, writ-
ten in Java language, which offers the con-
venience and possibilities for developments
of plugins for different purposes. In 2009,
development of ImageJ2 was initiated. Fiji
(Schindelin et al. 2012) is a software distribu-
tion that consists in ImageJ2 (Schindelin et
al. 2015) with many additional plugins prein-
stalled. ImageJ2 is mostly compatible with
ImageJ1 supporting the use of both old and
new plugins.
In this short guide, two alternative meth-

ods for object segmentation are described:

a) automated extraction with plugin SIOX
(Simple Interactive Object Extraction) and b)
manual threshold selection. Sample images
are shown in original form and after the dif-
ferent processing steps so as to facilitate a
better understanding for these two methods.
This article can also serve as an introduction
to the subject when the intention is to use
automated methods like that provided by the
ImageJ plugin Rosette Tracker (Vylder et al.
2012).

How to start

Area measurements such as the calculations
of leaf area or infected area are often needed
in biological research. Typically, this calcula-
tion is fulfilled by 4 steps: 1. Take a pho-
tograph that includes the target object on
an uncluttered and highly contrasting back-
ground; 2. Define the scaling: the conversion
factor between pixels (the actual units that
are counted in the photograph) into a unit
that has actual meaning to the user (e.g. milli-
metres); 3. Segment the object from the back-
ground; 4. Count the pixels in the segmented
object and convert this count into the quant-
ity of interest.
These steps indicate some key elements of

a successful calculation: a good photograph,
a good segmentation and a good conversion.
Once you have obtained a good photograph
of the object, ImageJ then will do the other
jobs.
Some years ago, I wrote a blog post, intro-
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ducing this area calculation using ImageJ1
(Schneider et al. 2012). By answering ques-
tions from readers, I have learnt that the
most difficult steps for those new to area
quantification in digital images is to learn
how to capture a good image and how to seg-
ment the object of interest as cleanly as pos-
sible. Here in this short guide, I introduce the
steps of using a segmentation plugin called
SIOX (Simple Interactive Object Extraction),
compare it with the method of manually set-
ting a threshold, and suggest some tips for
photographing suitable images. This guide
will help you understand better the meth-
ods used for image-area segmentation and
consequently make you aware of what image
characteristics help in the analysis. In addi-
tion you will better understand how both the
physical setup and illumination used for pho-
tographing together with correct camera set-
tings can help to obtain easy-to-analyze im-
ages.
Fiji (2.0.0) was used in this guide. Al-

though we used ImageJ under Apple’s OSX,
it can be also used under UNIX, Linux
and MS-Windows. Being free software, it
is widely available. Visit (http://imagej.
net/Citing) for information on how to cite
ImageJ and plugins. Fiji can be downloaded
from https://fiji.sc/.

SIOX

This section describes step by step how to
use the SIOX plugin using a photograph of
an Arabidopsis rosette as example. Fig. 8.1
shows the image in ImageJ at key steps in
the processing. In the instructions below, it-
alicized texts indicatesmenu selections in Im-
ageJ.

A1 Import image (of an Arabidopsis rosette
in this example). File > Open or drag the
image into Fiji window.

A2 Set scale (Figure 8.1a). Select straight line
tool on tool bar. Drag a line along one

side of the red square in the image. Ana-
lyze > Set Scale. Known Distance is the
length you dragged which is 3 cm. Tick
“Global” for applying this scale to all the
images generated from the sample im-
age.

A3 Segmentation (Figure 8.1b,c,d). Plugins
> Segmentation > SIOX:Simple Interact-
ive Object Extraction. Use Rectangu-
lar/Oval/Polygon/Freehand tool to select
a small area on the leaf area to be marked
as known as Foreground. Press Segment.
Create Mask.

A4 Calculation. Analyze > Analyze Particles
> Display Results/Summary.

Manual threshold

B1 See A1

B2 See A2

B3 Split channels (Figure 8.2a,b,c). Image >
Colour > Split Channels. This step can
sometimes be skipped, e.g. when the con-
trast between object and background is
high.

B4 Threshold (Figure 8.2d). Choose Blue
channel. Image > Adjust > Threshold.
Click freehand selection tool and select
the rosette area.

B5 Calculation. Analyze > Analyze Particles
> Display Results/Summary

Achieving a better result

Scale

The red cube in the sample image is the scale
to convert pixel of the image into the unit for
the area measurement which is centimetre in
our example. Many factors in photograph-
ing can distort the shape and size and sharp-
ness of the reference scale. For instance, the
depth of image or the distortion by the cam-
era lens. To keep it simple, the object used
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Figure 8.1: The steps of segmentation using SIOX: a) set scale; b) set foreground; c) refine the selec-
tion; d) the result of segmentation.
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Figure 8.2: Split colour channels and threshold
from same image of an Arabidopsis rosette as
in Fig. 8.1: a) red channel; b) green channel; c)
blue channel; d) the blue channel after applying
a threshold, with the selected are highlighted in
red.

Figure 8.3: Drawing of a copy stand, with three
angles that must be kept exactly at 90∘ marked.

as a reference scale should be located at the
same distance and position from the camera
as the target object. In other words, the two
of them should be at the same vertical dis-
tance to the camera, and the reference par-
allel to the sensor or film plane of the cam-
era. A copy stand is essential in many senses.
It helps to stabilize the camera and strictly
controls the level of the camera (Figure 8.3).
Rarely leaves will be laying flat on the ground,
so what is estimated with the methods de-
scribed here is area of the leaves or rosette
projected onto a reference plane. It also fol-
lows from this that some leaves or parts of
the leaves in an intact plant will be nearer
the camera than others. This source of un-
certainty is usually tolerable for rosettes, but
not for plants with stems. This problem does
not affect individual leaves scanned or photo-
graphed laying on a flat surface.

40 ©2016-2017 by the authors

http://www.uv4plants.org


UV4Plants Bulletin, 2016, no. 2

Colour channels

Images taken with colour digital camera con-
sist in three separate channels of red, green
and blue (RGB) sensor readings that when dis-
played or printed trick the human eye to see
something similar to the photographed ob-
ject or scene. In other words, normally the
colors are mixed by our human brain. One
way of obtaining a grayscale image is to dis-
play the luminosity values for a single color
channel (see Figures 8.2 and 8.4). Technic-
ally, if we combine the three images of cor-
responding to the red, green and blue chan-
nels (Figs. 8.2b,c,d), we can reconstruct the
original colour image of the rosette (Fig 8.2a).
Splitting the colour channels doesn’t change
the pixel resolution of the image. Thus, the
scale we defined in step A2 is valid for all the
images derived from the same original image
of the rosette (Fig. 8.2a). Thresholding can
only be applied to grayscale images. That is
why we have to split the channels (or alternat-
ively merge them) first. The easiest segment-
ation through a threshold is to classify pixels
into two output categories of black and white
(i.e. convert a scale with many different lu-
minance levels, or tones of grey, into a binary
scale by use of a luminance level threshold at
at chosen position along the grey scale). For
the example image, I choose the blue channel
because it is the channel with largest differ-
ence in luminosity between the rosette and
the background. Other images may require
the segmentation of one of the other chan-
nels.

Single channel threshold is ideal if the ob-
jects have large differences in color between
the areas to be segmented. This is the case
in the image of tulips taken under room light
with a DSLR (Digital single-lens reflex) camera
(Figure 8.4). The red flowers and green leaves
have high luminosity (look white) in the red
and green channels, respectively, while in the
blue channel they cannot be distinguished.
After splitting the three colour channels into
separate greyscale images, the channels suit-

Figure 8.4: A digital image of tulips and its three
colour channels: a) the original picture; b) the
red channel; c) the green channel; d) the blue
channel.
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Figure 8.5: Digital image in UVA region of a dan-
delion (Taraxacum spp.) flower. Light source:
365 nm from LEDs; camera: E-M1, Olympus,
Japan, converted to “full-spectrum” by DSLR As-
troTEC, Engen, Germany; filter: U-filter, Baader
Planetarium, Mammendorf, Germany; objective:
“accidental” UV transmitting Hannimex 35mm
f/3.5 No. 13368)

able for measuring flower and leaf areas are
easily identified.
The example images shown above are easy

to segment into areas of interest. Sometimes,
we cannot obtain images that are as good as
we would wish. Choosing a threshold manu-
ally is also useful for some objects, but the es-
timates obtained are more subjective. A pho-
tograph obtained under UVA illumination is
used as example (Figure 8.5).
The dark area at the centre of the flower,

visible only under UVA illumination, is of in-
terest as it is visible to insects such bees even
if not to humans. The luminosity of the dif-
ferent color channels in the absence of vis-
ible light is only the result of their different
sensitivities to UV radiation rather than their
designed differences in sensitivity to visible
colours. The weak colour visible in the image
is “false” as it is unrelated to human color
vision. However, segmenting this area with
the SIOX plugin is almost impossible because
there is little difference in color. In contrast,
thresholding on the separated colour chan-
nels returns very good results as there is a dif-
ference in luminosity. However, one should

Figure 8.6: Colour channel and the result of
threshold: a) Red channel of Figure 8.5; b)
threshold of a); the setting of the threshold.
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Table 8.1: Dark areas for dandelion flower. Selec-
tion tool Oval was used for selecting the area of
interest. Under the tool icon, x and y indicate the
center location of the oval area on the image; w
and h indicate the width and hight of the oval that
determine the oval area. To ensure the same loca-
tion and the same size of the selected area in each
channel, the parameters of x, y, w and h used were
exactly the same. The dark area is expressed both
as number of pixels, and as a percent of the selec-
ted area.

Image channel Dark pixels Dark area
(number) (%)

blue 2032379 48
green 1378071 36
red 1416709 40

bear inmind that the size of the selected dark
area will depend on the value chosen for the
threshold and on the channel used. Figure
8.6 shows an example of thresholding on the
red channel. In this image it is very clear that
thresholding also selects a large section of
the background. Before quantification, the
area of interest at the center of the flower
must the isolated with amask drawn by hand.
Drawing the mask is easy, as the white area
separating the center of the flower from the
background is very wide.

With the threshold set similarly for each
single channel image the area estimates vary
(Table 8.1). The area estimate for the blue
channel is larger for than the other two. This
is most likely due to differences in spectral
sensitivity within the UVA region of the three
channels of the camera’s image detector. In
Table 8.1 the areas are expressed in pixels as
there was no size reference available. One
could estimate the total area of the inflores-
cence and express the dark area as a ratio.
We leave this as an exercise for the reader to
try (The images are provided as supplement-
ary information for readers to practice on.)

Further reading

This article gives a simple introduction to
the most basic method of area estimation.
The process of area segmentation can be
automated within ImageJ and used to meas-
ure growth and other temporal changes in
plants. The Rosette Tracker plugin (Vylder et
al. 2012), available at http://telin.ugent.
be/~jdvylder/RosetteTracker/ together
with its documentation provides the next
step in sophistication when using time lapse
imaging. A recent comparison of methods
shows that consistency of quantification is
not easy to achieve (Scharr et al. 2015), high-
lighting the need for careful protocol design
and use. The ultimate in cost as well as
throughput are automated plant phenotyp-
ing systems. Other plugins for ImageJ al-
low different approaches to the quantific-
ation and measurement of different biolo-
gical structures at scales ranging from sub-
cellular to aerial images. There is a lot
more to explore, and a good way is to
read both scientific publications and less
formal technical reports. You can read the
essay at http://alvyray.com/Memos/CG/

Microsoft/6_pixel.pdf if you would like
to understand more about pixels (or voxels).
For further information on ImageJ you can
read tips on its use at http://imagej.net/
Category:Techniques. For a simple, mod-
ern and accurate account of technical (and
artistic) aspects of digital photography you
can read the two volumes Learning to Photo-
graph (Banek and Banek 2013a; Banek and
Banek 2013b).
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Our Tutorial articles distil existing in-
formation into an easy to follow set of in-
structions to perform a specific research-
related task. The contents is not required
to be scientifically original, but it should
not duplicate other readily available tu-
torials. The article above is a good ex-
ample of the type of submissions we
hope to receive under this category. We
invite all our readers to submit similar tu-
torials for techniques they are experts in.
These techniques can include from chem-
ical assays in the laboratory to measure-
ments in the field. For complex subjects,
we are also happy to publish tutorials in
installments over several Bulletin issues,
as long as each installment is readable
and useful on its own.

The editors.
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